Enjin Matrixchain has been upgraded successfully, completing the Sentosa mainnet upgrade.
Posted Dec 10, 2025 - 18:52 UTC
Update
Enjin Relaychain has been upgraded successfully.
Posted Dec 09, 2025 - 16:48 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 09, 2025 - 16:30 UTC
Update
Enjin Blockchain “Sentosa” Mainnet Upgrade – rescheduled
Enjin Blockchain maintenance for the Sentosa runtime upgrade has been rescheduled by 24 hours to allow for additional validation and coordination with infrastructure partners and node operators. During final pre deployment checks, we observed a non-critical behaviour in certain infrastructure configurations. To ensure a smooth rollout for the entire network, we are moving the Mainnet upgrade window to the times below.
New Maintenance Window: Enjin Relaychain Start: Dec 9, 16:30 UTC (approx. block 7,732,995) Enjin Matrixchain Start: Dec 9, 16:45 UTC (approx. block 7,732,995) End: Dec 9, 17:00 UTC
Impact: During the upgrade, the chain may reject extrinsics. Please wait until completion before submitting new extrinsics.
Node Operators: Please ensure your node clients are updated to the latest released versions compatible with the new runtimes (Relaychain v1.6.0 and Matrixchain v1.3.0) and complete any final checks ahead of the new window.
The Enjin Blockchain is currently operating normally and user funds and assets are safe.
Posted Dec 08, 2025 - 14:34 UTC
Scheduled
Enjin Blockchain is scheduled for maintenance in preparation for the ‘Sentosa’ runtime upgrade. The Sentosa upgrade advances the Enjin Relaychain to v1.6.0 and the Enjin Matrixchain to v1.3.0. Full details here: https://enjin.io/blog/enjin-blockchain-sentosa-upgrade
These changes have been live on Canary Testnet since October 27, 2025.
Maintenance Window (Mainnet): Start: Dec 8, 16:30 UTC — Relaychain block 13,229,687 (tentative); Matrixchain block 7,734,855 (tentative) End: Dec 8, 16:45 UTC
Impact: During the upgrade, the chain may reject extrinsics. Please wait until completion before submitting new extrinsics.
This scheduled maintenance affected: Wallet (Enjin Wallet), Marketplace (NFT.io), Platform (Enjin Mainnet), and Enjin Blockchain (Enjin Relaychain, Enjin Matrixchain).