Degraded access to Staking – Pool Overview in Enjin Wallet

Incident Report for Enjin

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 15:45 UTC

Update

We are continuing to investigate this issue.
Posted Aug 20, 2025 - 15:44 UTC

Investigating

An issue is preventing the Pool Overview screen in Enjin Wallet from loading for some mobile users. The technical team is currently investigating the cause and working to restore normal functionality. Apologies for the disruption.
Posted Aug 20, 2025 - 03:07 UTC
This incident affected: Wallet (Enjin Wallet).